Bekannte Probleme

FTP-Support fehlt

In der Grundeinstellung des LWS ist kein Zugriff per FTP auf andere Server möglich.

Lösung:
FTP-Support aktivieren

LWS starten und auf Menü -> PHP -> PHP-Erweiterungen klicken. Die Erweiterung für FTP ist derzeit inaktiv:

 

Nach Anklicken des Eintrages “ftp” wird die Erweiterung aktiviert und der Server neu gestartet:

 

Wie hier zu sehen ist nun der FTP-Support aktiviert und wir können vom LWS Verbindungen zu anderen FTP-Servern herstellen:

Quelle: https://stackoverflow.com/questions/18467876/ftp-connect-fatal-error-call-undefined-function…


Neue Websites werden immer mit alter WordPress-Version installiert

Neue WordPress-Websites werden manchmal mit einer alten WordPress-Version installiert und müssen zunächst ein Update erhalten. Das liegt daran, dass eine alte Version im Download-Ordner liegt und zur schnellen Installation (ohne Herunterladen vom Server) verwendet wird.

Lösung:
Die Datei …/laragon/usr/sites.conf öffnen:

Ganz oben in der Datei den Wert “Cached=false” einstellen und speichern.

Der Download dauert dann etwas länger, aber dafür wird die jeweils aktuelle Version direkt installiert.


Port 80 belegt:

Wenn der LWS nicht startet und diese Fehlermeldung anzeigt (Port 80 belegt),…

 

…klicken wir wie im oberen Bild angegeben auf Menu -> Tools -> netstart:

 

Hier sehen wir, dass der Port 80 von einer anderen Anwendung verwendet wird:

 

Im Suchfeld “appwiz.cpl” eingeben…

 

…und dann auf das Suchergebnis klicken:

 

Diesen Link anklicken…

 

…und überprüfen, ob der integrierte Microsoft-Webserver (IIS) gestartet ist. Dies trifft im Beispiel zu. Wenn dieser Dienst nicht benötigt wird,…

 

…entfernen wir die Markierung und bestätigen mit OK:

 

Danach ist ein Neustart des PCs erforderlich:

 

Der LWS sollte nach dieser Änderung korrekt starten.

 


Port 80 ist belegt und wird von der Anwendung (IIS oder anderer Webserver) benötigt:

Im LWS lässt sich der Standard-Port 80 leicht umschalten. Dazu klicken wir auf Menu -> Einstellungen…

 

…und geben im Register “Dienste Ports” anstatt “80” nun “8081” ein:

 

Der LWS startet automatisch neu und zeigt den eingegebenen Port “8081” an:

 

Kleiner Schönheitsfehler: Der geänderte Port taucht nun in der URL zusätzlich auf. Unabhängig davon läuft der LWS wieder einwandfrei: